18 de septiembre de 2018, 09:51:43 pm

Autor Tema: Problema HPLIP + HP3005 (Ex: Re:Problema para Instalar y Usar Impresoras: hp...)  (Leído 1102 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado EMATP

  • Novato
  • *
  • Mensajes: 7
  • Karma: +0/-0
Hola. Instale el HPLIP pero a diferencia de Cups y cuando voy a preferencias/impresion, no hay forma de que detecte las impresoras de red. Con los otros dos métodos la impresora HP 3005, que instalé en un servidor Debian, es detectada a través de la red pero no reacciona cuando envío una impresión. Alguien sabe que puede ser. Con cualquier otra máquina con cualquier sistema (linux o windows) las impresoras son detectadas y funcionan a travez de la red. Sin embargo con huayra me resulta imposible.


NdE: Extraido de otro hilo, por , para atender este tema por separado, con hilo propio
« Última Modificación: 25 de marzo de 2016, 12:16:30 pm por Comunidad Huayra »

Desconectado Comunidad Huayra

  • Vaqueros
  • Usuario Sr.
  • *
  • Mensajes: 412
  • Karma: +39/-0
  • Comunidad de Usuarios de Huayra GNU/Linux
    • Foros de la Comunidad de Usuarios de Huayra GNU/Linux
Re:Problema HPLIP + HP3005 (Ex: Re:Problema para Instalar y Usar Impresoras: hp...)
« Respuesta #1 : 25 de marzo de 2016, 12:17:29 pm »
¿Qué versión de Huayra utiliza?

Desconectado EMATP

  • Novato
  • *
  • Mensajes: 7
  • Karma: +0/-0
Re:Problema HPLIP + HP3005 (Ex: Re:Problema para Instalar y Usar Impresoras: hp...)
« Respuesta #2 : 28 de marzo de 2016, 07:38:51 pm »
Hola. La versión 2.2.

Desconectado Comunidad Huayra

  • Vaqueros
  • Usuario Sr.
  • *
  • Mensajes: 412
  • Karma: +39/-0
  • Comunidad de Usuarios de Huayra GNU/Linux
    • Foros de la Comunidad de Usuarios de Huayra GNU/Linux
Re:Problema HPLIP + HP3005 (Ex: Re:Problema para Instalar y Usar Impresoras: hp...)
« Respuesta #3 : 29 de marzo de 2016, 03:24:32 am »
Esa versión está basada en Debian Wheezy, no en Debian Jessie, como ocurre desde Huayra 3.0.

Ese detalle podría estar relacionado con la dificultad, y se resolvería instalando una versión mas actualizada de HPLIP, desde el sitio de esa herramienta.

Desconectado EMATP

  • Novato
  • *
  • Mensajes: 7
  • Karma: +0/-0
Re:Problema HPLIP + HP3005 (Ex: Re:Problema para Instalar y Usar Impresoras: hp...)
« Respuesta #4 : 30 de marzo de 2016, 10:51:09 am »
Tengo la versión 3.12.6-3.1+d i386 y según leo en la página de HPLIP la última version es la 3.16.3.
Pruebo instalando esa versión, veo que pasa y comento. Gracias.
Aprovecho para preguntar aunque sospecho que esta no es la sección correspondiente. ¿Cómo hago para poner en orden los repositorios de huayra? Muchas veces me dice que hay paquetes nuevos y sin embargo cuando pongo a actualizar no encuentra nada o cosas raras por el estilo. Eso lo hace desde que tengo la máquina. Quiero decir que me aparece una notificación de actualización y cuando pongo a actualizar revisa y no encuentra nada.
Saludos.

Desconectado EMATP

  • Novato
  • *
  • Mensajes: 7
  • Karma: +0/-0
Re:Problema HPLIP + HP3005 (Ex: Re:Problema para Instalar y Usar Impresoras: hp...)
« Respuesta #5 : 30 de marzo de 2016, 11:04:30 am »
_Huyra no me está dejando cambiar los permisos de los archivos. Es una locura.

Desconectado Comunidad Huayra

  • Vaqueros
  • Usuario Sr.
  • *
  • Mensajes: 412
  • Karma: +39/-0
  • Comunidad de Usuarios de Huayra GNU/Linux
    • Foros de la Comunidad de Usuarios de Huayra GNU/Linux
Re:Problema HPLIP + HP3005 (Ex: Re:Problema para Instalar y Usar Impresoras: hp...)
« Respuesta #6 : 30 de marzo de 2016, 11:12:32 am »
Si los archivos están en una carpeta protegida o "pertenecen" a un usuario protegido, para cambiar los permisos hay que usar el comando sudo, antes de chmod.

La otra consulta (repositorios), se recomienda ponerla en el foro del repositorio comhuayra, para que quede ordenada y se pueda atender mejor.

Desconectado EMATP

  • Novato
  • *
  • Mensajes: 7
  • Karma: +0/-0
Re:Problema HPLIP + HP3005 (Ex: Re:Problema para Instalar y Usar Impresoras: hp...)
« Respuesta #7 : 30 de marzo de 2016, 11:57:14 am »
Por más que use sudo no me cambia los permisos. Tanto en terminal como en modo gráfico me hace lo mismo. Copio los archivos (.run en este caso para poder instalar el hplisp) a un pendrive para no tener problemas con carpetas raras (el archivo esta en Descargas así que no debería tener problemas) pero pasa lo mismo. Tampoco me deja cambiar el grupo y usuario.

Desconectado Comunidad Huayra

  • Vaqueros
  • Usuario Sr.
  • *
  • Mensajes: 412
  • Karma: +39/-0
  • Comunidad de Usuarios de Huayra GNU/Linux
    • Foros de la Comunidad de Usuarios de Huayra GNU/Linux
Re:Problema HPLIP + HP3005 (Ex: Re:Problema para Instalar y Usar Impresoras: hp...)
« Respuesta #8 : 30 de marzo de 2016, 11:59:49 am »
si los archivos están en un pendrive formateado con formato FAT32 o algún formato de windows, los permisos NO funcionarán, ya que windows, y sus formatos, no pueden gestionarlos.

se recomienda copiar a la carpeta del usuario, para instalar desde ahí.

si los archivos están en la carpeta Descargas, en el espacio del usuario, deberían poder cambiarse los permisos.

En todo caso, puede ser conveniente revisar el propietario del archivo, crear una carpeta aparte para esa prueba, y si no se logra que funcione, copiar la salida completa de la terminal, para revisar los avisos.
« Última Modificación: 30 de marzo de 2016, 12:01:25 pm por Comunidad Huayra »

Desconectado EMATP

  • Novato
  • *
  • Mensajes: 7
  • Karma: +0/-0
Re:Problema HPLIP + HP3005 (Ex: Re:Problema para Instalar y Usar Impresoras: hp...)
« Respuesta #9 : 31 de marzo de 2016, 01:37:30 pm »
Hola de nuevo. Logré ejecutar el instalador pero ahora resulta que tiene problemas con las dependencias. Cuando fuerzo a instalarlas (sudo apt-get install libcupsimage2-dev por ejemplo) me dice que retuve paquetes rotos y que no se puede instalar. Ya probé con autoclean y otros comandos que andan por google pero nada. ¿Alguna idea?
« Última Modificación: 31 de marzo de 2016, 02:12:01 pm por EMATP »